Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 03, 2026 - 05:00 UTC
Scheduled
Dear Valued Customer,
We would like to inform you of a scheduled maintenance window for the LTL and TL services in EU region, during which we will be performing an internal infrastructure migration intended to improve the performance and reliability of our platform.
Maintenance Start: September 3, 2026, at 5:00 AM UTC Maintenance End: September 3, 2026, at 7:00 AM UTC
We do not expect any disruptions during this migration. Our team will be actively monitoring the migration
Regards, Customer Support
Posted Sep 02, 2026 - 15:35 UTC
This scheduled maintenance affects: EU - LTL (Visibility Operations Center (VOC), Dispatch API, Documents API, Rating API, Tracking API) and EU - Truckload (Visibility Operations Center (VOC), Network Management Center (NMC), Documents API, Rating API, Tendering API, Tracking API, Carrier VOC, Analytics, Booking API, Tracking Notifications).