Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2026 - 12:00 UTC
Scheduled
Dear Valued Customer,
We would like to inform you that we will be performing scheduled maintenance as part of our ongoing system upgrades for the Last Mile service.The affected region is North America(NA), and the maintenance window is scheduled for approximately 30 minutes.No customer impact is expected; however, during the rollout window, customers may experience brief intermittent errors or slightly increased latency.
Maintenance Start - March 26, 2026 12:00 PM UTC Maintenance End - March 26, 2026 12:30 PM UTC
As an organisation, we are committed to providing reliable and high availability service to our customers. In case of any questions, please do not hesitate to reach out to support@project44.com.
Regards, Customer Support
Posted Mar 25, 2026 - 16:48 UTC
This scheduled maintenance affected: NA - Last Mile (Data API, Orders API, Shipments API, Case Service API, Tracking Page, Application, Convey Website, Data Ingestion).