The issue affecting USPS last-mile tracking has been resolved by USPS. Our team is actively monitoring the situation to ensure continued stability.
We appreciate your patience and understanding. If you have any questions, please do not hesitate to contact us at support@project44.com.
Regards, Customer Support
Posted Apr 02, 2026 - 19:28 UTC
Identified
Dear Valued Customer,
We are currently experiencing an issue affecting USPS last-mile tracking. This disruption originates on the USPS side. Our team is actively collaborating with USPS to resolve the issue as quickly as possible.
As an organization, we are committed to providing reliable and high-availability service to our customers. In case of any questions, please do not hesitate to reach out to support@project44.com.
Regards, Customer Support.
Posted Apr 02, 2026 - 18:45 UTC
This incident affects: NA - Last Mile (Carrier Connections (Upstream Network)).