Truckload Visibility Service Disruption – North America

Incident Report for P44 Status Page

Resolved

Dear Valued Customer,

We are pleased to inform you that the issue affecting our Truckload Visibility service in the North America production environment has been fully resolved. All services are now functioning as expected.

We sincerely appreciate your patience and understanding while we worked to restore services.

As an organization, we are committed to providing reliable, high-availability services to our customers. If you have any questions, please don't hesitate to contact us at support@project44.com.

Best Regards,
Customer Support
project44
Posted Sep 19, 2025 - 18:57 UTC

Investigating

Dear Valued Customer,

We are currently experiencing an issue affecting our Truckload Visibility service in the North America production environment.

As a result, customers may face difficulties accessing real-time truckload visibility.

Our engineering team is actively investigating the root cause and working diligently to restore full functionality as quickly as possible.

Best Regards
Customer Support
project44
Posted Sep 19, 2025 - 17:53 UTC
This incident affected: NA - Truckload (Tracking API).