We would like to provide an update on the ongoing SMS notification issue affecting Appointment Manager and the DriveView app in the North America region, which has been identified by our upstream SMS service provider as related to toll-free number verification and is currently under priority review by their dedicated verification team.
Currently, SMS/text message notifications remain unavailable in the North America region, while all other Appointment Manager and DriveView functionality continues to operate normally.
We are closely monitoring progress with our provider and will share further updates as soon as there is a change in status or a more precise estimated resolution time, and we sincerely apologize for the inconvenience while appreciating your continued patience as we work to resolve this issue as quickly as possible.
Regards, Customer Support.
Posted May 06, 2026 - 07:15 UTC
Update
Dear Valued Customer,
We would like to provide an update on the ongoing SMS notification issue affecting Appointment Manager and the DriveView app in the North America region, which has been identified by our upstream SMS service provider as related to toll-free number verification and is currently under priority review by their dedicated verification team.
Currently, SMS/text message notifications remain unavailable in the North America region, while all other Appointment Manager and DriveView functionality continues to operate normally.
We are closely monitoring progress with our provider and will share further updates as soon as there is a change in status or a more precise estimated resolution time, and we sincerely apologize for the inconvenience while appreciating your continued patience as we work to resolve this issue as quickly as possible.
Regards, Customer Support.
Posted May 06, 2026 - 05:34 UTC
Identified
Dear Valued Customer,
We are currently investigating an issue affecting SMS notifications across both Appointment Manager and the DriveView app in the North America region. Drivers in NA region are not receiving text messages at this time.
The issue has been traced to our upstream SMS service provider. Our engineering team is actively engaged with the provider to determine the cause and restore service as quickly as possible.
Other Appointment Manager and DriveView functionality remains available. We will share another update as soon as we have more information.
Regards, Customer Support.
Posted May 05, 2026 - 17:06 UTC
This incident affects: YMS (Appointment Manager, Yard Visibility) and NA - Driveview.