Southeastern Freight Lines (SEFL) : LTL Rating and Booking Issue

Incident Report for P44 Status Page

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 00:03 UTC

Identified

Dear Valued Customer,

We have been informed by one of our LTL Carriers: "Southeastern Freight Lines" (SEFL) that they are experiencing systemwide network issues today which impacts their LTL rating and booking services. We are actively coordinating with SEFL on the same and shall keep you posted once more information becomes available.

Regards,
Customer Support.
Posted Jun 17, 2025 - 14:57 UTC
This incident affected: Upstream Network Providers (LTL Carrier).