AI Disruption Navigator Experiencing Partial Impact

Incident Report for P44 Status Page

Identified

Dear Valued Customer,

We would like to inform you that the issue affecting the AI Disruption Navigator has been identified, and our team is actively working with our partners to implement a resolution.

We apologize for any inconvenience this may have caused and sincerely appreciate your patience as we work to resolve this promptly.

We will continue to keep you updated as progress is made.

Regards,
Customer Support
Posted Sep 10, 2026 - 22:09 UTC

Investigating

Dear Valued Customer,

We are currently experiencing an issue with the AI Disruption Navigator in NA Production, resulting in customers being unable to read more about disruption events.

This has been classified as an incident. Our engineering team is actively investigating and treating this as a priority.

We will continue to provide updates here as they become available.

Regards,
Customer Support
Posted Sep 10, 2026 - 18:26 UTC
This incident affects: AI Disruption Navigator.