Collaboration Tab Degraded in Movement - NA

Incident Report for P44 Status Page

Monitoring

Dear Valued Customer,

We identified the underlying issue affecting the Collaboration tab in the Movement platform in NA Production and have applied a fix. Task interactions should now be working as expected, and we are continuing to monitor closely to ensure the issue does not recur.

We apologise for any inconvenience this may have caused.

Regards,
Customer Support.
Posted Sep 17, 2026 - 21:08 UTC

Investigating

Dear Valued Customer,

We are currently experiencing an issue with the Collaboration tab in the Movement platform in NA Production, resulting in task interactions failing or being slow intermittently.

Our engineering team is actively investigating and treating this as a priority.
We will continue to provide updates here as they become available.

Regards,
Customer Support.
Posted Sep 17, 2026 - 20:41 UTC
This incident affects: NA - Movement.