Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2026 - 10:08 UTC
Scheduled
Dear Valued Customer,
We would like to inform you that the scheduled maintenance on our Network Management Center (NMC) platform in the North America region is taking longer than originally anticipated. To ensure the successful completion of the infrastructure upgrade, the maintenance window has been extended by an additional 2 hours.
No customer impact or downtime is expected during this period, and the Network Management Center (NMC) platform will remain available throughout the maintenance.
Updated Maintenance Window
Maintenance Start: June 24, 2026, 06:30 UTC Revised Maintenance End: June 24, 2026, 12:00 UTC
As an organization, we remain committed to providing reliable and highly available services to our customers. We appreciate your patience and understanding while we complete this work.
If you have any questions, please do not hesitate to reach out to support@project44.com.
Regards, Customer Support
Posted Jun 24, 2026 - 10:07 UTC
This scheduled maintenance affected: NA - Truckload (Visibility Operations Center (VOC), Network Management Center (NMC), Tracking API, Tracking Notifications).