Omnitracs ELD Service Disruption – North America Region.

Incident Report for P44 Status Page

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 09:44 UTC

Identified

Dear Valued Customer,

We've been informed that the ELD provider, Omnitracs, is currently facing system delays. While the system is still operational, data processing is slower than usual, which may affect the quality and performance of shipments being tracked by Omnitracs. The provider has indicated that this issue may persist until Monday.

We will keep you informed of any updates as soon as we have more information.

As an organization, we are committed to providing reliable, high-availability service to our customers. If you have any questions, please do not hesitate to reach out to support@project44.com.

Best Regards,
Swathi
Operations Specialist
Posted Feb 08, 2025 - 00:13 UTC
This incident affected: Upstream Network Providers (TL Carrier/ELD).