Last Mile - Delay in Push Events

Incident Report for P44 Status Page

Resolved

Dear Valued Customer,

As per our monitoring, this issue is now resolved. Things are back to normal. Let us know if you notice any discrepancy, we would be happy to help.
Posted Apr 03, 2025 - 20:46 UTC

Monitoring

Dear Valued Customer,

A fix has been implemented, and our team is actively monitoring the situation. We will provide a final update once the monitoring process is complete. Thank you for your continued patience.

Regards,
Riona Lobo
Customer Support
Posted Apr 03, 2025 - 19:40 UTC

Update

Dear Valued Customer,

Our engineering team is actively addressing the issue and has identified a potential solution. Latency has been steadily decreasing as the team implemented additional measures. We will provide updates here as soon as we have more information. Stay tuned for further details.

Regards,
Riona Lobo
Customer Support
Posted Apr 03, 2025 - 18:21 UTC

Update

Dear Valued Customer,

The latency is decreasing gradually and slowly. We will keep this thread updated once we have further details.
Our engineering team is investigating and will continue to provide updates as more information becomes available.

Regards,
Riona Lobo
Customer Support
Posted Apr 03, 2025 - 15:36 UTC

Identified

Dear Valued Customer,

Our engineering team has been able to reduce the latency significantly. We are actively monitoring the situation and will provide a final update once the issue is fully resolved.

Regards,
Riona Lobo
Customer Support
Posted Apr 03, 2025 - 12:46 UTC

Investigating

Dear Valued Customer,

We are experiencing a disruption with Last Mile where in users may notice a delay in events coming through Push API. Our engineering team is investigating and we will continue to provide updates as more information becomes available.

As an organisation, we are committed to providing reliable and high-availability service to our customers. In case of any questions, please do not hesitate to contact support@project44.com.

Regards,
Riona Lobo
Customer Support
Posted Apr 03, 2025 - 10:38 UTC
This incident affected: NA - Last Mile (Data API, Shipments API).