The issue affecting our Last Mile product has been resolved. Order submission and processing are now functioning normally.
As an organization, we are committed to providing reliable, high-availability services to our customers. If you have any questions, please don't hesitate to contact us at support@project44.com.
Regards, Customer Support
Posted Apr 02, 2026 - 21:28 UTC
Update
Dear Valued Customer,
The issue affecting our Last Mile product has been resolved. Order submission and processing are now functioning normally.
As an organization, we are committed to providing reliable, high-availability services to our customers. If you have any questions, please don't hesitate to contact us at support@project44.com.
Regards, Customer Support
Posted Apr 02, 2026 - 21:27 UTC
Investigating
Dear Valued Customer,
We are currently investigating an issue affecting our Last Mile product. Some customers may experience delays when attempting to submit and process orders, resulting in slower-than-usual system performance. Our engineering team is actively working to resolve this issue and mitigate any impact as quickly as possible.
We apologize for any inconvenience this may cause and appreciate your patience as we work towards a resolution.
As an organization, we are committed to providing reliable, high-availability services to our customers. If you have any questions, please don't hesitate to contact us at support@project44.com.
Regards, Customer Support
Posted Apr 02, 2026 - 20:30 UTC
This incident affected: NA - Last Mile (Orders API, Application, Data Ingestion).