Intermittent delays in Ocean Shipment Updates and CTT Access Interruption

Incident Report for P44 Status Page

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 16:28 UTC

Monitoring

Dear Valued Customer,

We would like to inform that our customers may still intermittently experience delays in ocean shipment updates. Additionally, those using the Container Track & Trace (CTT) system directly may face availability issues when accessing the CTT API and UI.

We apologize for any inconvenience this may cause and appreciate your understanding.

As an organization, we are committed to providing reliable and high-availability service to our customers. In case of any questions, please do not hesitate to reach out to support@project44.com.

Regards,
Abhra Roy Choudhury
Posted Mar 19, 2025 - 13:55 UTC
This incident affected: NA - Container Track & Trace (CTT) (Track & Trace Web Application (CTT), Track & Trace API) and EU - Container Track & Trace (CTT) (Track & Trace Web Application (CTT), Track & Trace API).