Ward Transport & Logistics (LTL Carrier) - Disruption
Incident Report for P44 Status Page
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 16:10 UTC
Identified
Dear Valued Customer,

Ward Transport & Logistics (WTL) have made significant progress restoring their systems. Although not all internal and customer-facing systems are fully functional, they are in a position to confidently operate and make pickups and deliveries. Currently, WTL's IT department is working to provide service to their customers in a safe and secure manner.

We shall make sure to keep our status page posted with all the latest updates made available by WARD.

Alternatively, kindly refer the website: https://www.wardtlc.com/ for latest updates as well.

---

The issue is confined to the carrier's system and does not affect the operation of the project44 system or any related companies. As a precautionary measure to ensure the security of our customers, the connection between p44 and Ward Transport & Logistics still remains temporarily disabled until the situation is resolved.

Best Regards,
Customer Support
project44
Posted Mar 07, 2024 - 11:10 UTC
Investigating
Dear Valued Customer,


We have been informed that one of LTL Carriers - Ward Transport & Logistics (WTL) has experienced a cyberattack that has impacted multiple layers of their organization. Currently, WTL's IT department is diligently working on recovery at this time.

If you have any immediate concerns or require further assistance, please do not hesitate to contact WTL's support team at: https://www.wardtlc.com/ or via their Customer Service team at 1-800-458-3625.

---

The issue is confined to the carrier's system and does not affect the operation of the project44 system or any related companies. As a precautionary measure to ensure the security of our customers, the connection between p44 and Ward Transport & Logistics has been temporarily disabled until the situation is resolved.

As an organization, we are committed to providing reliable and high-availability service to our customers. In case of any questions, please do not hesitate to reach out to support@project44.com.

Best regards,

Customer Support
project44
Posted Mar 04, 2024 - 17:52 UTC
This incident affected: Upstream Network Providers (LTL Carrier).